5
5 баллов

Данная инструкция переведена с оригинала GLPI версии 9.5 и актуальна на 01.11.2022 г.

Требования

GLPI — веб приложение, которое требует:

  • веб сервер;
  • PHP;
  • БД;

Веб сервер

GLPI требует веб сервер, который поддерживает PHP:

PHP

GLPI VersionMinimum PHPMaximum PHP
9.4.X5.67.4
9.5.X7.28.0
10.0.X7.48.1
PHP Compatibility Matrix

! Примечание

Мы рекомендуем использовать новейшую поддерживаемую версию PHP для повышения производительности.

Обязательные расширения

Следующие расширения PHP требуются для правильной работы GLPI:

  • curl: для CAS аутентификации, проверки версии GLPI , Telemetry, …;
  • fileinfo: для получения дополнительной информации из файлов;
  • gd: для генерации изображений;
  • json: для поддержки данных в формате JSON;
  • mbstring: для поддержки мультибитовых кодировок;
  • mysqli: для поддержки и запросов к БД;
  • session: для поддержки сессий пользователей;
  • zlib: для поддержи резервного копирования и восстановления БД;
  • simplexml;
  • xml;
  • intl.

Дополнительные расширения

! Примечание

Даже если эти плагины необязательны, мы, в любом случае, рекомендуем их установить.

Следующие PHP расширения требуются для некоторых дополнительных функций GLPI:

  • cli: для использования PHP из коммандной строки (скрипты, автоматические действия и тд);
  • domxml: используется для CAS аутентификации;
  • ldap: используется для аутентификации через LDAP сервер;
  • openssl: защищенные соединения;
  • xmlrpc: используется для XMLRPC API.
  • APCu: может использоваться для кеширования; среди прочих (смотри конфигурацию кеширования (только на французском).

Конфигурация

В конфигурационным файле PHP (php.ini) должен быть настроены следующие переменные:

memory_limit = 64M ;        // max memory limit
file_uploads = on ;
max_execution_time = 600 ;  // not mandatory but recommended
session.auto_start = off ;
session.use_trans_sid = 0 ; // not mandatory but recommended

База данных

! Предупреждение

В настоящее время GLPI поддерживает только серверы баз данных MySQL (минимум 5.7) и MariaDB (минимум 10.2).

Для работы GLPI требуется сервер БД.

Источник: https://glpi-install.readthedocs.io/en/latest/prerequisites.html


Нравится? Поделитесь с друзьями!

5
5 баллов

Какова Ваша Реакция?

Конфуз Конфуз
0
Конфуз
Милый Милый
0
Милый
Черт Черт
0
Черт
Провал Провал
0
Провал
Забавно Забавно
0
Забавно
Зануда Зануда
0
Зануда
Хейт Хейт
0
Хейт
lol lol
0
lol
Лайк Лайк
1
Лайк
Любовь Любовь
1
Любовь
OMG OMG
0
OMG
Страшно Страшно
0
Страшно
Тошнота Тошнота
0
Тошнота
Победа Победа
0
Победа
WTF WTF
0
WTF
Счастье Счастье
1
Счастье
Дизлайк Дизлайк
0
Дизлайк
Ржака Ржака
0
Ржака
Пес

0 Комментариев

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Share via